记录一些常用的函数和瞎折腾的过程……

禁用wordpress5.0的Gutenberg(古腾堡)编辑器

wordpress5.0已经发布,最大的变化就是使用了Gutenberg(古腾堡)编辑器,这个编辑器真叫一个难用。

网上有教程说使用插件的方式可能禁用Gutenberg(古腾堡)编辑器,其实不用那么复杂,两行代码即可解决,就可以实现禁用Gutenberg编辑,继续使用原有的编辑器。

在当前主题的functions.php中增加以下代码:

1、禁用Gutenberg(古腾堡)编辑器:

add_filter('use_block_editor_for_post', '__return_false');

2、禁用后,前端还是会加载相关的的样式文件,还需要加上一句:

remove_action( 'wp_enqueue_scripts', 'wp_common_block_scripts_and_styles' );

 

《禁用wordpress5.0的Gutenberg(古腾堡)编辑器》没有评论
发表评论